ZCP 6.40 from source on Ubuntu 10.04

From Zarafa wiki

Jump to: navigation, search

For this document I start with a vanilla Ubuntu 10.04 server installation, which I use it to build the Zarafa Collaboration Platform (ZCP) 6.40.0 rc6 Community Edition from source.

Make sure to get Ubuntu up-to-date with:

sudo aptitude update
sudo aptitude safe-upgrade

First the following requirements have to be installed:

sudo aptitude install apache2 postfix libapache2-mod-php5 mysql-client slapd \
  mysql-server tinyca ca-certificates libcurl3 libssh2-1 build-essential \
  php5-dev libtool pkg-config uuid-dev libmysqlclient-dev gettext libz-dev \
  libldap2-dev automake debhelper flex bison libcurl4-gnutls-dev libssl-dev \
  libxml2-dev libncurses5-dev libclucene-dev

When you are presented with a dialog to setup the MTA, choose "Internet Site" and pick an appropriate name.

Now Download the ZCP Community source package. Move this tarball to /usr/local/src/zarafa-6.40-chosen.tar.gz. Then do the following:

cd /usr/local/src
# libical 0.44
wget http://download.zarafa.com/mirror/libical-0.44.tar.gz
tar xvzf libical-0.44.tar.gz
cd libical-0.44
./configure 
make; sudo make install
cd ..

# libvmime 0.7.1 + patches
wget http://downloads.sourceforge.net/project/vmime/vmime/0.7/libvmime-0.7.1.tar.bz2
tar xvjf libvmime-0.7.1.tar.bz2
wget http://developer.zarafa.com/download/zarafa-vmime-patches.tar.gz
mkdir zarafa-vmime-patches
tar xvzf zarafa-vmime-patches.tar.gz -C zarafa-vmime-patches
cd libvmime-0.7.1
for i in ../zarafa-vmime-patches/*.diff; do patch -p1 < $i; done
./configure
make; sudo make install
cd ..

# zarafa 6.40.0
tar xvzf zarafa-6.40-chosen.tar.gz
cd zarafa-6.40.*
./configure --disable-static --disable-testtools \
  --with-userscript-prefix=/etc/zarafa/userscripts \
  --with-quotatemplate-prefix=/etc/zarafa/quotamails \
  --prefix=/usr --sysconfdir=/etc
make; sudo make install
ls /usr/bin/zarafa-*  # shows that it worked

Voila! ZCP from source.

For other distribution it should be largely the same procedure.


Known issues

A know issue exists for build 19949, the make process will fail with the following message:

[...]
make  install-am
make[4]: Entering directory `/usr/local/src/zarafa-6.40.0/installer/linux'
make[4]: *** No rule to make target `zarafa-licensed.logrotate', needed by `all-am'.  Stop.
make[4]: Leaving directory `/usr/local/src/zarafa-6.40.0/installer/linux'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/usr/local/src/zarafa-6.40.0/installer/linux'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/zarafa-6.40.0/installer'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/zarafa-6.40.0'
make: *** [install] Error 2

This is fixed in later builds. As the effects are minimal you could simply use make -k, with the -k flag it will continue after errors. This issue is also mentioned on the forum.

Personal tools